Friday, January 23, 2009

A technical question

A few of the blogs I follow are using some sort of new comment form that looks like this


My problem is, this form doesn't seem to work with Firefox - my browser of choice. I select "Google Profile", type in my comment and press "Post Comment" - and nothing happens. If I open the blog in Internet Explorer then it works as expected, prompts me to enter my google userid/password and post my comment.

My question is: Is this just me? Is anybody else able to use Firefox with this type of comment?

It's just a pain to have to bring up IE just to write a comment - and why doesn't it remember my userid and password? I really really have to want to make that comment; more often than not, I won't bother.

Or, maybe that's viewed as a good thing - maybe Abelard's comments are all that appreciated.

Anyway, I just wanted to check to see if this is a common problem - or just a problem for me. And, if anybody has ideas for how I can get this type of comment to work with the Firefox 3.0.5 browser.

10 comments:

Alan said...

I use Firefox and had the same problem.

Kengo Biddles said...

Abelard, I use Firefox and don't have that problem. What version of Firefox are you running? I'm on version 3.0. If you're not, you may want to upgrade to 3.0.

And isn't that they type of comment that my newest blog has? You were the first one to post...did you have to switch to Internet Exploder?

Abelard Enigma said...

Kengo

3.0.5
Yes
Yes

So, Firefox works for you but not for Alan or me. Hmmm

Chedner said...

I use Firefox, and such works for me.

Do you have javascript disabled?

Amanda said...

I use firefox and it works for me, though I really dislike the format. I prefer a regular popup box or a separate page rather than the little entry box.

Rebecca said...

I'm pretty sure this is the same format that our original template came with, and no one was able to make comments on it. However, I believe we have solved it by changing our settings; we switched the comment box being "embedded below post" to a "pop-up window."
Anyone experiencing this problem with their blog may want to give that a try.

Abelard Enigma said...

I think I may have solved the problem. You have to configure Firefox to accept third party cookies.

Now I forgot what I was going to say in my comment. I guess I'll have to wait until I have some other brilliant thought to share to confirm if this really works :)

Hidden said...

Or if Firefox doesn't work, you can use another browser.

Such as google chrome. Which is way cool and faster than Firefox, actually.

Pshhh. IE. I NEVER open IE. EVER.

Sarah said...

Or try Flock--that is Scott and my browser of choice for blogging. It is great for blog feeds and facebook, too!

Scott said...

... except that Flock is based on Firefox, so it may not work any better.

(It does have tons of nice features related to blogging and social networks, though. I highly recommend it: www.flock.com)